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Overview 

 
 
League Scheduler is an easy to use scheduling program that creates your game schedule for a 
whole season. 
To get started, please review the Quick Start Guide and  Frequently Asked Questions    
 
When you create a schedule you'll select the type as Regular or Traveling. Select Traveling if you 
have home and away games. If you have multiple age groups or skill levels, you'll create a 
separate schedule for each one (e.g. U12, U14). Each age group can have up to 40 teams.  
 
The program generates many different reports to help you manage your schedule including 
League Schedule, Condensed Schedule, Team Schedules, Location Schedules, Master 
Schedule, Game Scores, Audit, and Standings.  
 
After your schedule is computed, use  Edit Schedule to make adjustments.  Comments can also 
be added to the schedule.  
 
Once your games start, enter game scores and the team standings are automatically tracked. 
When viewing the report, click Preferences to customize how team standings are determined. 
There's also an available game times function that can be used to reschedule games due to 
rainouts, etc. 
 
Click {Publish.bmp} on the toolbar to publish your own League Website to the Internet with One-
Click.  You can publish your website to www.allprosoftware.net for FREE or to your own 
registered domain.  
 
For additional help at any time, click on the Help button on any screen, press F1 on your 
keyboard, or click on the Help Menu.  
 
Back up your database regularly to protect against loss due to power failure, disk damage or 
other mishaps.  This is very important! 
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Quick Start Guide 

 
 

 
The Select Schedule screen comes up automatically when you start the program.  There's a 
sample League and Schedule for you to experiment with.  You can delete these any time. It's a 
good idea to read through the Frequently Asked Questions when you get a chance. This will help 
speed up your understanding of how League Scheduler works. 
To view specific help information, click on the Help button on any screen or Press F1 on your 
keyboard anywhere in the program. 
  
Add a League: 
  
1. Each Schedule belongs to a League, so the League must be added first. Click Leagues button 
on the Select Schedule screen.  Click Add.  
 
2. Enter the League Name.  (tip: Enter the name of your organization, sport, or specific season, 
e.g. Centerville YMCA, Lincoln Youth Basketball, 2011 Fall Ball). League Name is required.  All 
other fields are optional. Click OK. Click Close.   
 
Add a Schedule for a League: 
 
3. Click Schedules button on the Select Schedule screen.  Click Add. 
 
4. Enter Schedule Name and Type. (tip: Enter the age division or group for the Schedule Name, 
e.g. U12 Boys, 8th Grade Girls, Pony, T-ball). 
      The schedule name and type are required.  All other fields are optional.  (tip: If you have 
home and away games, choose  Traveling.) Click OK to save. If you have multiple age groups or 
skill levels, Click Add to enter another schedule name for the next age group.  
  
5. Click Setup (lower right) on the Select Schedule screen. 
    
6. Enter all the schedule parameters by clicking on each of the six parameter buttons: Locations, 
Teams, Start Date, Game Times, Exceptions, and Options.  On each parameter screen, after 
entering info, click Close to return to the Setup Schedule screen.  Press F1 on any screen to read 
specific help. 
 
7. Click Compute (lower right) on the Setup Schedule screen.  The program will compute the 
entire schedule according to the parameters you've supplied.  
 
8. The League Schedule Report is automatically displayed after the schedule is computed. To 
check overall game balancing, select Audit from the Report Menu.  
 
9.    Select Edit Schedule from the Update Menu to make manual adjustments as needed. If you 
need to add or reschedule games, you can view open time slots by selecting Available Game 
Times from the Tools menu. (tip: After you've made edits, make sure you don't compute the 
schedule again. If you do compute again, your edits will be lost!).     
 
10. Check for conflicts by selecting Check Conflicts from the Tools Menu.  This allows you to 
check for scheduling conflicts (e.g., a team playing at two locations at the same time).  
 
11. To enter scores, select Game Scores from the Update Menu. Select a date on the calendar 
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and Click Update. Team standings are automatically tracked. Click Preferences to customize how 
team standings are determined.    
 
12. View any of your League and Schedule Reports by selecting a report from the Reports Menu.  
Select Print from the File menu to print any reports. 
 
13. To create your free League Website, select Internet Options from the Internet Menu.  This is 
where you select the reports, and pictures to include on your Website.  Use the tabs along the top 
of this screen to navigate.  Add custom text on the Page Content tab.  Click OK when finished.   
 
14. Select Publish Website from the Internet Menu.  You are prompted for a name the first time 
you publish.  You can re-publish anytime to update your Website as the season progresses. All 
schedules within a league are published to the same website. If you create another separate 
league, it will be published to a separate website name.       
   
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



All-Pro League Scheduler User Manual   Page 5  

 

Frequently Asked Questions 

 
 

 
Is there specific help for where I am in the program? 
Press F1 anywhere in the program to show specific help for the current window. 
 
How do I create a schedule? 
Quick Start Guide has all the steps needed to create a schedule. 
 
I have several different age divisions in my League. How should I set that up? 
First add one overall League for your organization, e.g. Youth Basketball. Then add multiple 
Schedules (one for each age group) to the League e.g. U10 Boys, U12 Boys.   
 
How many teams can I add to a schedule? 
Each schedule represents a group of teams (e.g., U12 Boys, 8th Grade Girls, T-ball). You can 

have up to 40 teams in each schedule group. 

 
Can I create schedules for more than one league? 
Yes, you can create schedules for multiple leagues. Click on Leagues from the Update Menu and 
click Add to create another league.  
 

 
How do I email a report? 

When viewing a report, Click on the upper left to start the export. In the first drop down list, 
select the format. Options include Word for Windows and PDF. In the second drop down list, 
select Application and click OK. This starts the appropriate application such as Microsoft Word or 
Adobe and puts the report information directly into it. From there you can edit and save the file 
just as you normally would in the application. Once the file is saved, you can start an email and 
send the document as a file attachment.  
 
Can I import a list of team names? 
Yes, you may import team names or location names from a comma separated file or other All-Pro 
software programs by selecting Import Names and Locations from the Tools Menu.  
 
Can I make changes to a schedule after it's computed? 
Yes, select Edit Schedule from the Update Menu to make changes to your schedule. Remember, 
do not compute your schedule again after making changes. 
 
How do I customize the Standings Report? 
When viewing the report, click on the Preferences button to change how team ranking is 
determined and to choose which fields to display on the report. You can choose Runs, Points or 
Goals For and Against.  You can show Games Behind or Points.  If you show Points, you can 
assign point values for wins, losses and ties in regulation and overtime games. You can also 
select the sort fields for tiebreakers.   
 
Can I export a schedule? 
Yes, you may export a schedule to a comma separated file (CSV), iCalendar (ICS), vCalendar 
(VCS) or Google Calendar format, by selecting Export Schedule from the Tools Menu.  
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How do I find the game times that weren't used after computing a schedule? 
Select Available Game Times from the Tools Menu.  This can be used to help reschedule a 
game. 
 
How can I find out which schedules a team is on? 
Select Teams from the Update Menu, select the team and then click Show Schedules. 
 
How often should I back up my data? 
Backing up your data after making changes to a schedule or adding game scores would be best.  
It's easy and could save you time and grief.  Just select Back Up Database from the File Menu. 
We recommend saving your backup file to a USB flash drive. To restore from a backup, select 
Restore Database from the File Menu. 
 

 
Can I use multiple divisions to schedule my whole league? 
Divisions are not to be used for schedules within a league but for divisions within a schedule (for 
example Eastern and Western Divisions). 
 
Can I use both the End Date and Times Teams Play Each Other options to compute a 
schedule? 
No.  In Schedule Options you must select one or the other.  Otherwise the scheduler would have 
to add or remove arbitrary game times to fit both options and the result would rarely be 
acceptable. 
 
What are schedule exceptions? 
Schedule exceptions are the added or removed date specific game times for the compute logic to 
use.  For example, you could remove all game times for July 4th or add an extra game on August 
11th at 8:00pm at Location1.  These are the exceptions to the game times entered on the Game 
Times screen. 
 
What's the difference between schedule exceptions and team exceptions? 
Schedule exceptions are described above.  Team exceptions are used when a specific team can't 
play all day, before a certain time or after a certain time for a specific day of the week or date 
range.  For example, Team1 can't play before 7:00pm on July 1st to July 15th. 
 
Can teams share a home location on a Traveling Schedule? 
Yes.  However, they can't share the same game times.  Two teams can't have their home games 
on Tuesday at 7:00pm at Field1.  But one team could play their home games on Tuesday at 
7:00pm at Field1 and the other team on Tuesday at 8:00pm at Field1. 
 
Can I schedule double-headers? 
You can schedule double-headers for Traveling schedules by entering two game times on the 
same day for each team.  Two teams would play each other twice at the home team's location.  
See game times for more information.  For Regular schedules, you can only add double-headers 
from the Edit Schedule Screen after the schedule has been computed.  Although on some 
schedules, a team could play more than once in a day. 
 
Can I add comments to a schedule? 
Yes, click the Select button on the League Schedule Report or Condensed Schedule Reports to 
add comments that can be displayed before or after the schedule.  Click Add or Change on the 
Edit Schedule Screen to add comments for individual games. 
 
How do I add game scores? 
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Click on the toolbar or select Game Scores from the Update Menu to add game scores 
after a schedule has been computed.  Forfeits, rainouts, cancelled games and comments can 
also be recorded. 
 
How do I change the team numbers on the reports? 
Click Change Number on the Schedule Teams screen to change the team number.  Team 
numbers can be from 1 to 9999.  Team numbers can be changed after a schedule is computed. 
 
How do I change a report title? 
On the League, Schedule and Team Information Reports, click Title to make a change.  On all 
other report screens, click Select to change the report title. 
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Toolbar 

 
 
The League Scheduler Toolbar items: 
 

   Select Schedule - Select and Update Leagues and Schedules. 
 

   Edit Schedule - Edit Schedule for the selected schedule. 
 

   Update Game Scores - Update Game Scores for the selected schedule. 
 

   League Schedule Report - Display the League Schedule Report. 
 

 

   Team Schedule Report - Display the Team Schedule Report. 
 

 

   Master Schedule Report - Display the Master Schedule Report. 
 

   Audit Report - Display the Audit Report. 
 

 

   Standings - Display the Standings Report. 
 

 

   Print - Print the displayed report. 
 

   Font - Used for reports on Reports Menu.  
 

   Internet Options - Set the Internet Options for publishing your League Website. 
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   Publish League Website - Publish your League Website to the Internet. 
 

   Frequently Asked Questions - Go to the Frequently Asked Questions section in Help. 
 

   Help - Run the Help Program you are viewing.  
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Select Schedule 

 
 
The Select Schedule screen lists all leagues on the left and all schedules within the selected 
league on the right.  Each schedule belongs to a league so you must add a league before you 
add a schedule. 
 
To get started, please review the Quick Start Guide and Frequently Asked Questions 
 
Click Leagues to add or change a league name. You can add multiple leagues. Click Schedules 
to add or change a schedule name within the selected league.  If you have multiple age groups, 
add a schedule name for each one. Click Setup to set the schedule parameters (locations, teams, 
start date, game times, exceptions and options) and to compute a schedule.  After a schedule is 
computed you can click Edit to make changes. 
 
Check Picture Gallery to view the pictures in the Picture Gallery Directory.  To show the Leagues 
List, Picture Gallery must be unchecked.  Click Find Picture to select the Picture Gallery 
Directory.  Use the Arrow Buttons or select from the drop-down list to view another picture.  The 
pictures in the Picture Gallery Directory can be selected when you publish your League Website. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



All-Pro League Scheduler User Manual   Page 11  

 

Update Leagues 

 
 
Select Leagues from the Update Menu or click Leagues on the main Select Schedule screen to 
add, change and delete league information.  You can add any number of leagues.  For each 
league you can add any number of schedules.  Every schedule belongs to a league so you need 
to add the league first. 
 
Tip: For the League Name, use organization name, sport name, or specific season. For example: 
Centerville YMCA, Lincoln Youth Basketball, 2011 Fall Ball.   
 
The only required entry field is the League Name.  All other fields are optional.   
 
When you delete a league, all schedules and game scores added to the league will also be 
deleted so be careful. To delete multiple leagues, hold down the Ctrl key and select each league 
you want to delete and then click on the Delete button.  
 
Click League Information on the Reports Menu to show the League Information Report.  
 

 

Update Schedules 

 
 
Select Schedules from the Update Menu or click Schedules on the main Select Schedule screen 
to add, change and delete schedule information.  You can add any number of schedules.  Every 
schedule belongs to a league so you need to add a league first. 
 
Tip: For the Schedule Name, use age division, age group, or skill level. For example: U12 Boys, 
8th Grade Girls, Pony, T-ball.   
 
You must enter a Schedule Name and select a Schedule Type.  The other entry fields are 
optional.   
 
For the Schedule Type, select Regular if teams share locations for home games. Select Traveling 
if teams have home and away games. For Traveling schedules, each team is assigned a home 
location after you add the team name on the Teams screen.  
 
*** See Traveling Schedule Setup for complete details on creating a traveling schedule.   
 
When you delete a schedule, all game scores added to the schedule will also be deleted so be 
careful.  To delete multiple schedules, hold down the Ctrl key and select each schedule you want 
to delete and then click on the Delete button.  
 

 
Click Schedule Information on the Reports Menu to show the Schedule Information Report.  
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Schedule Types 

 
 
The League Scheduler creates two types of round-robin schedules: 
 
Regular Schedules share locations between all teams.  You might have 2 locations shared 
between 8 teams where any team could play any home game at any location. For example, city 
softball leagues generally work this way.  When you compute this type of schedule, game times 
and locations are randomly assigned.  So each time you compute the same schedule team 
matchups could be at different locations and game times so you can compute the schedule over 
and over until you come up with what you want or until it's close to what you want.  Schedules 
may only require one compute and you're done.  With more complicated schedules that have 
Schedule Exceptions or Team Exceptions you might compute the schedule more than once 
looking for one closest to what you need.  You can select Copy Schedule from the File Menu to 
save a computed schedule so it won't be overwritten when the schedule is recomputed or for 
backup purposes.  You can edit (add, change and delete games) a schedule after it's computed 
but the edits will be lost if you compute the schedule again. 
 
Traveling Schedules are different in that each team is assigned a location to play their home 
games and the schedule is computed differently.  When you enter game times on the Game 
Times Screen you are entering a time for a team to play a home game but it doesn't necessarily 
mean a game will be played at that time every week.  For example, if you have 8 teams you 
would enter a weekly game time for each team for a total of 8 weekly game times.  However, 
when you compute the schedule only 4 games will be scheduled each week because the game 
time is only used if the team is playing at home that week.  Unlike the regular league schedule, 
computing a traveling league schedule more than once will not create a different schedule unless 
you made parameter changes.  You can edit the schedule after it's computed. 
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Traveling Schedule Setup 

 
 
Instructions for Traveling Schedule Setup 
 
The setup of a traveling schedule allows you to set a home location for each team.  In doing so 
you are guaranteeing that teams play their home games on their home field and away games on 
their opponent's home field.   
 
You will first need to set that schedule up as a Traveling Schedule.  Click on the Schedules 
button and then add or change a schedule, selecting Traveling Schedule as the schedule type.  
 
Next go into Setup for that schedule. 
 
Enter the Locations for all the teams in this schedule. 
 
Enter the Teams.  You will notice a Home Locations button under the team list on the right hand 
side.  Highlight a team from that team list and click on the Home Locations button to choose a 
home field for that team.  You will now notice an (H) next to the team name which denotes that 
team has been assigned a home location.  Repeat the Home Location assignment for the rest of 
the teams.  All Teams must be assigned a home location in a traveling schedule setup.  
***League Scheduler can have teams be assigned to the same home location, but the teams 
cannot have the same Game Times as the other teams that share that home location.  This is 
explained in detail in the next section***   
 
Click the Game Times button, to set the home game times for each team.  Click on a team and 
then use the day and time controls to assign game times for that team. 
***A couple of notes about game times:   
1) The game times that you are setting up for teams are the times when they will be playing their 
home games only, away games will be played on days/times setup for the other teams.     
2) The number of game time's setup for each team must be the same and must be equal to the 
number of games that teams will play in a week.  (i.e. If your league is one that plays only one 
game per week, each team will be setup with only one game time.  If you are a league that plays 
a week day game and a weekend game, your teams will be setup with one weekday game time 
and one weekend game time.)   
3) If you have teams that share a home location, those teams cannot have the same game times 
setup.  (i.e. Team A and Team B share Field 1, set Team A's game times as Mon and Wed at 
6pm and Team B's as Tues and Thurs at 6pm)   If you don't have enough location availability and 
need to have the same game times for the shared location teams, there is a way to fake the 
software.  It does require some work to edit the schedule after it has been computed, but it will 
get you close enough that that isn't too much additional work.  To do this, set Team A to play at 
6pm and Team B to 6:01pm.  After doing this, you will need to go through and clean up the 
conflicts that may be created in doing that, but there is detail below on doing that as well.   
To set Game Times, click on a team and then use the day and time controls to add game times 
for that team.  Set the times for all your teams and then click OK. 
 
If you have any days when games can't be played, you can set them in the Exceptions area.  For 
instance you could choose to not play any games on Memorial Day. Click on May 25th and click 
Add. Click Remove, check All Day and make sure All Locations is highlighted. Click OK.  You will 
see a listing saying games times have been removed for each of the locations. The software will 
now skip putting games on that day.  Click Setup to return to the schedule setup area. 
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Set the schedule Start Date 
 
Next go into Options. Set the Compute Option for this schedule.  This is an OR option area so 
you can only choose one of the options.  'Times teams play each other' or 'Each team plays the 
same number of games' are the best choices as the software will generate a schedule with the 
same number of games for all the team.  The End Date option will attempt to create the same 
number of games for the teams but it may not. Set how you want the software to Check for 
Defaults, and then click OK. 
 
Click Compute to generate the schedule. When finished the league schedule report will pop up.  
Check the schedule over, if you need to you can go back and Compute the schedule again to get 
a completely different schedule.  Sometimes you may need to compute the schedule a number of 
times to get desired results.   
 
****If you did the fake game times as discussed earlier, click on Tools then Check for Conflicts. 
Put a checkmark in for your schedule and make sure 'check for overlapping game times' is 
checked and click OK. This will list the conflicts found.  If it is more than 3 or 4, I would compute 
the schedule again.  Repeat the compute/check for conflicts until you only have a few conflicts. 
 
Once you have only a few conflicts print out the check for conflicts screen and then you can 
manually edit the schedule to adjust the games to the opponent's location or to a different 
time/day.  To do this, click on Update then Edit Schedule. Click on the date that has one of the 
conflicts. Find either the 6 or 6:01 games and click change. Pick the opponents location for the 
game and if it was the 6:01 game change the time to 6 and click OK or change it to a different 
day/location and click ok. Make all the changes necessary to clean up the conflicts on the 
printout. Check for conflicts again to make sure you didn't create any on this process. 
 
When you have no more conflicts, go into the edit schedule again and change all the game times 
from 6:01 to 6. 
 
You should also take a look at the audit report to make sure that teams have a close to even 
number of home games and make adjustments if necessary, also verify that each team plays the 
correct number of games. 
 

 

 

 

Setup Schedule 

 
 
Select Setup Schedule from the Update Menu, use Ctrl+S or click Setup on the Select Schedule 
screen to add schedule parameters and to compute a schedule. 
 
Click on the parameter buttons to set the Locations, Teams, Start Date, Game Times, Exceptions 
(for example no games on July 4th) and Options and then click Compute to create a schedule.  
After you click Compute to create a schedule, the League Schedulet Report is displayed. See the 
Quick Start Guide for more information on how to create a schedule. 
 
General parameter information entered for a schedule is displayed under Schedule Parameters.  
If the schedule has been computed, the Start Date, End Date, Scheduled Games and Scores 
Added totals are displayed under Computed Schedule and the days on the calendar with 
scheduled games will be blue.  Click Previous Month or Next Month to scroll through the months. 
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Changing schedule parameters after a schedule has been computed does not change the 
schedule.  You must compute the schedule again to have the parameter changes affect the 
schedule.  However, when you compute a schedule again, the previous schedule is 
completely overwritten and any edits or game scores that were added are lost. 
 
Click Edit to bring up the Edit Schedule screen where you can add, change and delete games on 
a schedule.  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Schedule Locations 

 
 
Click Locations under Parameters on the Setup Schedule Screen to add, change and delete 
locations on the schedule.  All locations added to the database are listed on the left and the 
locations added to the schedule are listed on the right.  Use the arrow buttons to add and remove 
locations on the schedule. 
 
To import a list of locations, click on the Tools Menu and select Import Teams and Locations  
 
When you add a location, it is also added to the schedule. When you change the name of a 
location, it affects all schedules it has been added to.  You can't delete a location that has been 
added to another schedule.  To delete multiple locations, hold down the Ctrl key and select each 
location you want to delete and then click on the Delete button.  
 

 
** Important ** If you have multiple courts or fields in one place, make sure you enter each 
playing surface as a separate location (e.g. Westview Field 1, Westview Field 2, Westview Field 
3).   
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Schedule Teams 

 
 
Click Teams under Parameters on the Setup Schedule screen to add, change and delete teams 
on a schedule.  All teams added to the database are listed on the left and the teams added to the 
schedule are listed on the right.  You can add up to 40 teams to a schedule.  Use the Arrow 
Buttons to add and remove teams on the schedule. 
 
To import a list of teams, click on the Tools Menu and select Import Teams and Locations  
 
When you add a team, it's also added to the schedule. When you change the name of a team, it 
affects all schedules it has been added to.  You can't delete a team that has been added to 
another schedule. 
 
If you have 2 teams in different groups using the same name, you must change the name to be 
unique, e.g. Raiders 1 and Raiders 2. If you only add one team called Raiders and use that name 
in two schedules, your schedules will not be correct.  
 
You can add any number of divisions to a schedule.  If you don't have multiple divisions, then 
work with "No Divisions" as the selected division.  Select a division from the list and add the 
teams.  Divisions are not to be used when you have multiple groups within a single age group for 
example Eastern and Western Divisions. 
 
Click Change Number to change the number that will be displayed on the League Schedule 
report for the selected team.  Team numbers from 1 to 9999 are allowed. 
 
For Regular Schedules, click Exceptions to add exceptions for the selected team.  An example of 
team exceptions is a team can't play before 8:00pm from July 1st to July 15th.  The number of 
exceptions added is displayed next to the team. 
 
For Traveling Schedules, click Home Location to assign a location for the selected team to play 
its home games.  Each team must be assigned a home location before you can compute the 
schedule. 
 
To delete multiple teams at one time, hold down the Ctrl key on your keyboard and click on each 
team you want to delete and then click on the Delete button.    
 

 

Update Division 

 
 
Enter a Division Name and press OK.  The name of the division must be unique to the schedule 
but not to other schedules.  For example, you could add an Eastern Division to every schedule. 
 
If you add two or more divisions to a schedule, the number of times teams play each other can be 
different inside and outside the division and is entered on the Schedule Options screen.  
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Change Team Number 

 
 
When you add a team to a schedule, a team number is automatically assigned to the team.  You 
can change the number to any number from 1 to 9999.  You can change a team number after the 
schedule has been computed because it will not affect the scheduled team matchups, only the 
team number displayed on the report. 
 
The team number is only used on the League Schedule and Condensed Schedule reports.  On 
the Condensed Schedule Report it is used to identify the teams matchups.  
 

 

Team Exceptions 

 
 
Select a team and click Exceptions on the Schedule Teams screen to add exceptions that will be 
used in computing the schedule.  Team exceptions are not available for Traveling schedules. If 
the team exceptions added are causing the program to leave game times unfilled, you can 
compute the schedule without team exceptions and then edit the schedule. 
 
Team exceptions are based on the Day of Week or Date Range and are:  

  No Games All Day.  

  Games Must Start AFTER a specific time.  

  Games Must Start BEFORE a specific time. 
 
The number of exceptions added for a team is indicated on the Schedule Teams screen.  
Schedule Exceptions are different from Team Exceptions.  
 

 

Home Location 

 
 
Click Home Location on the Schedule Teams screen to assign a home location to a team.  This is 
only available for Traveling schedules. 
 
Each team must be assigned a home location before you can compute the schedule.  Teams can 
share a home location but you can't enter the same day of the week game time for them.  For 
example, Team1 and Team2 can share Location1 but you can't enter a Wednesday game time of 
7:00pm for both.  You could add a Wednesday game time of 7:00pm for one team and 8:00pm for 
the other and edit the schedule after it's been computed if necessary.  
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Schedule Start Date 

 
 
Click Start Date on the Setup Schedule screen to select the start date for computing a schedule.  
Changing the start date does not affect a computed schedule but will be used the next time the 
schedule is computed.  
 

 

Schedule Game Times 

 
 
Click Game Times under Parameters on the Setup Schedule screen to enter weekly game times 
that will be used to compute a schedule.    
 
For Regular schedules, game times are entered for each location.  When you compute a regular 
schedule, the scheduler will try to schedule a game for each game time entered on this screen 
unless an exception has been added to remove that game time for a specific date. 
 
For Traveling schedules, game times are entered for each team.  When you compute a traveling 
league schedule, the scheduler will try to schedule a game for a team's game time only if the 
team is playing at home.  All teams must have the same number of game times entered.  Since a 
game time is used only for home teams, if you enter 20 game times you will probably get 10 
games per week when you compute the schedule.  To schedule double-headers for traveling 
leagues, enter two game times on the same day of the week. 
 
To add a game time, select a location or team, select a game time for a day of the week and click 
Add Game Time.  Click Delete to delete a game time and Clear to clear all game times for the 
selected location or team.  You can select 1, 5 or 15 minute increments for the game times in 
Options. 
 
To select multiple teams or locations, hold down the Ctrl key and select each location or team 
then click Add Game Time.  
 
The Length of Game is used only for conflict checking and is very important if you're working with 
multiple schedules.  For example, two games scheduled at the same location with overlapping 
game times and team playing at 2 different locations with overlapping game times.  
 

 

Schedule Exceptions 

 
 
Select Exceptions on the Setup Schedule screen to add, change and delete exceptions for a 
schedule.  Exceptions are the added or removed date specific game times for the compute logic 
to use.  For example, you could remove all game times for July 4th or add an extra game on 
August 11th at 8:00pm at Location1.  These are the exceptions to the game times entered on the 
Game Times screen. 
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On the Schedule Exceptions screen, you process one date at a time.  Click Previous Month or 
Next Month to scroll through the months.  On the calendar, click the day of the month you want to 
work with.  Days with exceptions added will be blue.  The day you have selected will be red and 
the exceptions for that date will be listed on the right. 
 
Click Add to add a game exception.  To change or delete an exception, select an exception on 
the list and click Change or Delete. 
 
You must compute the schedule after you add exceptions for them to be incorporated into the 
schedule.  Click Setup to bring up the Setup Schedule screen where you can compute the 
schedule. 
 
See Team Exceptions for the other exception type. 
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Schedule Options 

 
 
Select Options on the Setup Schedule screen to select Compute Options, Team Options, 
Compute Methods and whether you want to check for Conflicts With Other Schedules.  You can 
only choose one Compute Option.  Different schedules can have different options.  The maximum 
length for a computed schedule is 1 year. 
 

Compute Options (cannot be used in combination):  

  Times teams play each other.  For example, you might want each team to play each other 4 

times.  If you have multiple divisions, you would enter the number of times you want each team to 
play each other inside and outside of their division.  You would also choose whether to Alternate 
with Inside Division Games First, Alternate with Outside Division Games First, All Inside Division 
Games First, All Outside Division Games First, or Mix Inside and Outside Division Games.  The 
scheduler will attempt to schedule the inside and outside division order the way you selected but 
it doesn't always work.  For multiple divisions with Traveling Schedules, you don't have the option 
to choose X times inside and outside the division but just X number of times for all teams.  

  Use end date.  The scheduler will create a schedule through the end date selected.  The 

maximum length for a computed schedule is 1 year from the start date.  If you use an end date 
and after you compute the schedule you don't have enough games, you can add more game 
times and compute the schedule again.  If you have too many games, you can remove some 
game times and compute the schedule again.  

  Each team plays the same number of games.  For example, you might want each team to 

play 10 games regardless of how many teams are on the schedule.  A team won't necessarily 
play each other team the same number of times. 
 

Team Options (not available for traveling leagues):  

  Maximum games per day.  The default is 1 game per day.  

  Maximum games per week.  For computing purposes, a week starts on Monday and ends on 

Sunday.  

  Minimum days off between games.  0 would mean that a team could play every day.  2 

would mean a team must have 2 days off between games.  For example, if a team plays on 
Monday it couldn't play again until Thursday.  However, this does not affect the number of times a 
team can play on the same day. 
 

Compute Methods (not available for traveling leagues):  

  Compute Method 1.  Try this Compute Method first because it balances game times and 

locations best.  However, if some game times are skipped using this method, try Compute 
Method 2.  After you compute the schedule check the Audit Report.  

  Compute Method 2.  This Compute Method does the best job at filling game times.  Because 

Compute Method 1 balances game times and locations better, we suggest you only use this 
method when Compute Method 1 skips game times. 
 

Conflicts With Other Schedules  

  Do not schedule games that conflict with other schedules.  Check this option so when the 

schedule is computed games do not conflict with other schedules (two games scheduled at the 
same time and location, team playing at 2 different locations at the same time, two games 
scheduled at the same location with overlapping game times, team playing at 2 different locations 
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with overlapping game times).  After you compute the schedule, if some game times aren't filled it 
might be because those game times conflict with other schedules.  You can compute the 
schedule again without this option checked and Check for Conflicts from the Tool Menu to see if 
that's the case.  When checking this option and using Compute Method 2, balancing game times 
can be very poor.  

  Any Schedules.  Check all schedules for conflicts including checking for overlapping game 

times based on the length of game entered on the Schedule Game Times Screen.  

  Selected Schedules.  Check only selected schedules for conflicts.  Before the schedule is 

computed, the Check for Conflicts Screen will be displayed where you can select the schedules 
to check for conflicts and whether you want to check for overlapping game times.  You might 
exclude checking for conflicts with a copy of a schedule that is being used for backup.  
 

 

League Schedule Report 

 
 

Click on the toolbar, use Ctrl+L or select League Schedule from the Reports Menu to 
display the League Schedule Report.  The team number, name and contact information are 
displayed at the top of the report.  Game dates, times, locations, and team matchups showing full 
team names are displayed in the body of the report.  Select the Condensed Schedule Report for 
a schedule showing team numbers for matchups. 
 
Team Numbers can easily be changed.  Select Setup Schedule from the Update Menu and then 
click Teams under Parameters.  Team Numbers can be 1 to 9999. 
 
Click Preferences to change the fields shown on the report and to choose the report format. On 
the Preferences screen, Check/uncheck Locations, Location w/Date, Contacts, and Comments to 
customize the report. The Comment checkbox is used to optionally display individual game 
schedule comments entered on the Edit Schedule Screen.  
   
Click Select to change the date range, change the report title or add report comments. 
 

Click on the toolbar or select Print from the File Menu to print the report.  Select Select 

Printer from the File Menu to switch printers.  Click to export the report to Word, and other 
formats. 
 
Select a Zoom percentage or enter your own to change the report zoom.  Change the report font 
type by selecting from the font drop-down list on the toolbar.  Select Options from the Tools Menu 
to change the report colors, default zoom percentage and whether you want to display the date 
on the report. 
 
When you publish your League Website, this report can be included if selected in Internet 
Options. 
 
To export a report: 
 

Click on the upper left to start the export. In the first drop down list, select the format. Options 
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include Word for Windows and PDF. In the second drop down list, select Application and click 
OK. 
  

  
 
This starts the appropriate application such as Microsoft Word or Adobe and puts the report 
information directly into it. From there you can edit and save the file just as you normally would in 
the application. Once the file is saved, you can start an email and send the document as a file 
attachment.  
 

 

 

 

 

Condensed Schedule Report 

 
 
Select Condensed Schedule from the Reports Menu to display the Condensed Schedule Report.  
The team number, name and contact information are displayed at the top of the report.  Game 
dates, times, locations and team matchups showing team numbers are displayed in the body of 
the report.  Select the League Schedule Report for the schedule showing full team names for 
matchups. 
 
Team Numbers can easily be changed.  Select Setup Schedule from the Update Menu and then 
click Teams under Parameters.  Team Numbers can be 1 to 9999. 
 
Check/uncheck Locations, Contacts, and Comments to customize the report. The Comment 
checkbox is used to optionally display individual game schedule comments entered on the Edit 
Schedule Screen. 
   
Click Select to change the date range, change the report title or add report comments. 
 

Click on the toolbar or select Print from the File Menu to print the report.  Select Select 

Printer from the File Menu to switch printers.  Click to export the report to Word, and other 
formats. 
 
Select a Zoom percentage or enter your own to change the report zoom.  Change the report font 
by selecting from the font drop-down list on the toolbar.  Select Options from the Tools Menu to 
change the report colors, default zoom percentage and whether you want to display the date on 
the report. 
 
To export a report: 
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Click on the upper left to start the export. In the first drop down list, select the format. Options 
include Word for Windows and PDF. In the second drop down list, select Application and click 
OK. 
  

  
 
This starts the appropriate application such as Microsoft Word or Adobe and puts the report 
information directly into it. From there you can edit and save the file just as you normally would in 
the application. Once the file is saved, you can start an email and send the document as a file 
attachment.   
 

 

Team Schedules Report 

 
 

Click Missing image: teamschedulesreport.bmp on the toolbar, use Ctrl+T or select 

Team Schedules from the Reports Menu to display the Team Schedules Report.  Schedules for 
each team added to the league schedule are displayed showing game dates, times, locations and 
opponents. 
 
Check/uncheck Locations, Contacts, and Record to customize the report. The Record checkbox 
is used to optionally display game scores Game Scores screen.   
   
Click Select to change the date range, change the report title or add report comments. 
 

Click on the toolbar or select Print from the File Menu to print the report.  Select Select 

Printer from the File Menu to switch printers.  Click to export the report to Word, and other 
formats. 
 
Select a Zoom percentage or enter your own to change the report zoom.  Change the report font 
by selecting from the font drop-down list on the toolbar.  Select Options from the Tools Menu to 
change the report colors, default zoom percentage and whether you want to display the date on 
the report. 
 
When you publish your League Website, this report can be included if selected in Internet 
Options. 
 
To export a report: 
 

Click on the upper left to start the export. In the first drop down list, select the format. Options 
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include Word for Windows and PDF. In the second drop down list, select Application and click 
OK. 
  

  
 
This starts the appropriate application such as Microsoft Word or Adobe and puts the report 
information directly into it. From there you can edit and save the file just as you normally would in 
the application. Once the file is saved, you can start an email and send the document as a file 
attachment.   
 

 

Game Scores Report 

 
 
Select Game Scores from the Reports Menu to display the Game Scores Report.  Game dates, 
times, locations, team matchups and game scores for the schedule are displayed.  If a game 

score has not been entered for a game, "..." will be displayed for the score.  Click on the 
toolbar or select Game Scores from the Update Menu to add scores, forfeits, rainouts, cancelled 
games and game comments. 
 
Check/uncheck Locations, Location w/Date and Comments to customize the report. The 
Comment checkbox is used to optionally display individual game score comments entered on the 
Game Scores screen.   
 
Click Select to change the date range, change the report title or add report comments. 
 

Click on the toolbar or select Print from the File Menu to print the report.  Select Select 

Printer from the File Menu to switch printers.  Click to export the report to Word, and other 
formats. 
 
Select a Zoom percentage from or enter your own to change the report zoom.  Change the report 
font by selecting from the font drop-down list on the toolbar.  Select Options from the Tools Menu 
to change the report colors, default zoom percentage and whether you want to display the date 
on the report. 
 
When you publish your League Website, this report can be included if selected in Internet 
Options. 
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To export a report: 
 

Click on the upper left to start the export. In the first drop down list, select the format. Options 
include Word for Windows and PDF. In the second drop down list, select Application and click 
OK. 
  

  
 
This starts the appropriate application such as Microsoft Word or Adobe and puts the report 
information directly into it. From there you can edit and save the file just as you normally would in 
the application. Once the file is saved, you can start an email and send the document as a file 
attachment.   
 

 

Standings Report 

 
 

Click on the toolbar or select Standings from the Reports Menu to display the Standings 
Report.  The report shows Games Won (Won), Games Lost (Lost), Win Percentage (Win%), 
Winning or Losing Streak (Streak), Runs For (RF), Runs Against (RA) and either Games Behind 
(GB) or Points (Pts) and Scoring Differential (Diff).   
 
Click Select to compute the report for any date range, change the report title, or add report 
comments. 
 
Click Preferences to change how ranking is determined and to choose which fields to 
display on the report.  

  Rankings - Select whether to Show Games Behind (GB) or Points (Pts).  Games behind could 

be used for baseball and softball. Points could be used for hockey. 

  For and Against - Select whether to display Runs, Points or Goals. RF and RA stand for Runs 

For and Runs Against.  PF and PA stand for Points For and Points Against.  GF and GA stand for 
Goals For and Goals Against. 

  Points - Only available if Show Points was selected under Standings - Rankings. Select the 

points (0 to 5) to assign a win, loss and tie in regulation and overtime games.  

  Determine Ranking by - Select the primary and tie-breaker sorts for the standings.  Head to 

Head means one team against another team.  Points refer to "Standings - Points" and not the 
score. Wins is the total number of wins.   
 

 
Streak is the latest consecutive number of wins or losses by a team.  For example, if a team has 
lost its last 5 games then the Streak is "Lost 5".  If a team won its last game but lost the game 
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before that, the Streak would be "Won 1". 
 
Win Percentage (Pct) is computed as ((wins + ties) / total games) where wins are 1 point, ties are 
1/2 point and losses are 0 points.  If you select to display Games Behind (GB), note that a team 
could be listed first because they have the highest win percentage and still be 1/2 or more games 
behind.  For example, a 1-0 team will be listed first but will be 1/2 game behind a 3-1 team.  This 
frequently occurs in Major League Baseball at the beginning of the season. 
 
Scoring Differential is computed as Runs/Points/Goals For minus Runs/Points/Goals Against.  
 

Click on the toolbar or select Print from the File Menu to print the report.  Select Select 

Printer from the File Menu to switch printers.  Click to export the report to Word, and other 
formats. 
 
Select a Zoom percentage or enter your own to change the report zoom.  Change the report font 
by selecting from the font drop-down list on the toolbar.  Select Options from the Tools Menu to 
change the report colors, default zoom percentage and whether you want to display the date on 
the report. 
 
When you publish your League Website, this report can be included if selected in Internet 
Options. 
 
To export a report: 
 

Click on the upper left to start the export. In the first drop down list, select the format. Options 
include Word for Windows and PDF. In the second drop down list, select Application and click 
OK. 
  

  
 
This starts the appropriate application such as Microsoft Word or Adobe and puts the report 
information directly into it. From there you can edit and save the file just as you normally would in 
the application. Once the file is saved, you can start an email and send the document as a file 
attachment.   
 

 

 

 

 

 

 



All-Pro League Scheduler User Manual   Page 27  

 

League Information Report 

 
 
Select League Information from the Reports Menu to display the League Information Report.  
Contact, Home Phone, Work Phone, Cell Phone, Fax Number, Address, Email and Notes are 
listed for the selected league. 
 
Click Update to change the League Information.  Click Title and Comment to change the report 
title and add report comments. 
 

Click on the toolbar or select Print from the File Menu to print the report.  Select Select 

Printer from the File Menu to switch printers.  Click to export the report to Word, and other 
formats. 
 
Select a Zoom percentage or enter your own to change the report zoom.  Change the report font 
by selecting from the font drop-down list on the toolbar.  Select Options from the Tools Menu to 
change the report colors, default zoom percentage and whether you want to display the date on 
the report. 
 
When you publish your League Website, this report can be included if selected in Internet 
Options. 
 
To export a report: 
 

Click on the upper left to start the export. In the first drop down list, select the format. Options 
include Word for Windows and PDF. In the second drop down list, select Application and click 
OK. 
  

  
 
This starts the appropriate application such as Microsoft Word or Adobe and puts the report 
information directly into it. From there you can edit and save the file just as you normally would in 
the application. Once the file is saved, you can start an email and send the document as a file 
attachment.   
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Schedule Information Report 

 
 
Select Schedule Information from the Reports Menu to display the Schedule Information Report.  
Contact, Home Phone, Work Phone, Cell Phone, Fax Number, Address, Email and Notes are 
listed for the selected schedule.  Whether locations are assigned to home teams or randomly to 
games is also shown. 
 
Click Update to change the Schedule Information.  Click Title and Comment to change the report 
title and add report comments. 
 

Click on the toolbar or select Print from the File Menu to print the report.  Select Select 

Printer from the File Menu to switch printers.  Click to export the report to Word, and other 
formats. 
 
Select a Zoom percentage or enter your own to change the report zoom.  Change the report font 
by selecting from the font drop-down list on the toolbar.  Select Options from the Tools Menu to 
change the report colors, default zoom percentage and whether you want to display the date on 
the report. 
 
When you publish your League Website, this report can be included if selected in Internet 
Options. 
 
To export a report: 
 

Click on the upper left to start the export. In the first drop down list, select the format. Options 
include Word for Windows and PDF. In the second drop down list, select Application and click 
OK. 
  

  
 
This starts the appropriate application such as Microsoft Word or Adobe and puts the report 
information directly into it. From there you can edit and save the file just as you normally would in 
the application. Once the file is saved, you can start an email and send the document as a file 
attachment.   
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Team Information Report 

 
 
Select Team Information from the Reports Menu to display the Team Information Report.  
Contact, Home Phone, Work Phone, Cell Phone, Fax Number, Address, Email and Notes are 
listed for each team on the schedule.  You can select a team from the drop-down list to only show 
that team's information. 
 
Select a team from the drop-down list and click Update to change the Team Information.  Click 
Title and Comment to change the report title and add report comments. 
 

Click on the toolbar or select Print from the File Menu to print the report.  Select Select 

Printer from the File Menu to switch printers.  Click to export the report to Word, and other 
formats. 
 
Select a Zoom percentage or enter your own to change the report zoom.  Change the report font 
by selecting from the font drop-down list on the toolbar.  Select Options from the Tools Menu to 
change the report colors, default zoom percentage and whether you want to display the date on 
the report. 
 
When you publish your League Website, this report can be included if selected in Internet 
Options. 
 
To export a report: 
 

Click on the upper left to start the export. In the first drop down list, select the format. Options 
include Word for Windows and PDF. In the second drop down list, select Application and click 
OK. 
  

  
 
This starts the appropriate application such as Microsoft Word or Adobe and puts the report 
information directly into it. From there you can edit and save the file just as you normally would in 
the application. Once the file is saved, you can start an email and send the document as a file 
attachment.   
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Master Schedule Report 

 
 

Click on the toolbar, use Ctrl+M or select Master Schedule from the Reports Menu to bring 
up the Select for Report Screen to change the report title and to select the date range, schedules 
and locations for the report.  You can also click Select on the report screen to select your report 
parameters. 
 
Check/uncheck Locations, Location w/Date and Schedules to customize the report.  If you check 
Schedules, a Schedule Index is displayed to identify which schedule the games are on. 
 

Click on the toolbar or select Print from the File Menu to print the report.  Select Select 

Printer from the File Menu to switch printers.  Click to export the report to Word, and other 
formats. 
 
Select a Zoom percentage or enter your own to change the report zoom.  Change the report font 
by selecting from the font drop-down list on the toolbar.  Select Options from the Tools Menu to 
change the report colors, default zoom percentage and whether you want to display the date on 
the report. 
 
When you publish your League Website, this report can be included if selected in Internet 
Options. 
 

 
To export a report: 
 

Click on the upper left to start the export. In the first drop down list, select the format. Options 
include Word for Windows and PDF. In the second drop down list, select Application and click 
OK. 
  

  
 
This starts the appropriate application such as Microsoft Word or Adobe and puts the report 
information directly into it. From there you can edit and save the file just as you normally would in 
the application. Once the file is saved, you can start an email and send the document as a file 
attachment.   
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Audit Report 

 
 

Click on the toolbar, use Ctrl+A or select Audit Report from the Reports Menu to display the 
Audit Report.  The report can be automatically displayed after a schedule is computed by a 
selection in Options.  The Audit Report is a very important tool you can use to determine if the 
schedule will work for you.  You can always edit the schedule and then return to the Audit Report 
to review the counts. 
 
Counts are shown for Rainouts and Cancelled Games, Home and Visitor, Game Times, Days of 
the Week, Locations and Team vs Team.  Rainouts and cancelled games are not included in the 
other counts.  These counts can be selected from the drop-down list or you can display ALL Audit 
Counts.   
 
Click Select to change the date range, change the report title, or add report comments. 
 

Click on the toolbar or select Print from the File Menu to print the report.  Select Select 

Printer from the File Menu to switch printers.  Click to export the report to Word, and other 
formats. 
 
Select a Zoom percentage or enter your own to change the report zoom.  Change the report font 
by selecting from the font drop-down list on the toolbar.  Select Options from the Tools Menu to 
change the report colors, default zoom percentage and whether you want to display the date on 
the report. 
 
To export a report: 
 

Click on the upper left to start the export. In the first drop down list, select the format. Options 
include Word for Windows and PDF. In the second drop down list, select Application and click 
OK. 
  

  
 
This starts the appropriate application such as Microsoft Word or Adobe and puts the report 
information directly into it. From there you can edit and save the file just as you normally would in 
the application. Once the file is saved, you can start an email and send the document as a file 
attachment.   
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Location Schedules Report 

 
 
Select Location Schedules from the Reports Menu to bring up the Select for Report Screen to 
change the report title and to select the date range, schedules and locations for the report.  You 
can also click Select on the report screen to select your report parameters. 
 
Check/uncheck Schedules to customize the report.  If you check Schedules, a Schedule Index is 
displayed to identify which schedule the games are on. 
 

Click on the toolbar or select Print from the File Menu to print the report.  Select Select 

Printer from the File Menu to switch printers.  Click to export the report to Word, and other 
formats. 
 
Select a Zoom percentage or enter your own to change the report zoom.  Change the report font 
by selecting from the font drop-down list on the toolbar.  Select Options from the Tools Menu to 
change the report colors, default zoom percentage and whether you want to display the date on 
the report. 
 
When you publish your League Website, this report can be included if selected in Internet 
Options. 
 
To export a report: 
 

Click on the upper left to start the export. In the first drop down list, select the format. Options 
include Word for Windows and PDF. In the second drop down list, select Application and click 
OK. 
  

  
 
This starts the appropriate application such as Microsoft Word or Adobe and puts the report 
information directly into it. From there you can edit and save the file just as you normally would in 
the application. Once the file is saved, you can start an email and send the document as a file 
attachment.   
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Available Game Times Report 

 
 
This report lists the game times not used by a schedule.  The report is useful for finding available 
game times in order to reschedule a game or for aiding in manual schedule editing.  
 
Click Select to quickly adjust your search parameters, by bringing up the Available Game Time 
Parameters screen.  You can use the parameters from the Schedule Game Times Screen or you 
can select your own.  
 
Click on an available game time and then click Edit to get the Edit Schedule Screen for that game 
date.  Click Add to add a game to the schedule.  If you do edit the schedule be sure to use the 
Check for Conflicts option on the Tools Menu, as this function does not stop overlapping game 
times.  
 

 

Available Game Time Parameters 

 
 
Select the parameters for the Available Game Times Report to list game times not used by a 
schedule.  The report is useful for finding available game times in order to reschedule a game or 
for aiding in manual schedule editing.  
 
Select a date range to search for available game times by entering a Start Date and End Date. 
 
The Schedule option will use the Location, Day of Week and Game Time parameters previously 
entered in the Schedule Game Times screen, in order to process the report. 
 
The Select option allows you to set those parameters or narrow them down in order to process 
the report.  Only Locations initially added to the schedule are available to select.  If you need to 
be able to select a different location, you will first need to add the location on the Schedule 
Locations screen. 
 
All Schedules will make sure the available game times do not conflict with other schedules. 
 
Support Game Exceptions will ensure any removed game times under Schedule Exceptions will 
not display on the report. 
 
This function does not check for overlapping game times so it's a good idea to Check for Conflicts 
from the Tools Menu if the schedule is changed.  
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Select for Report 

 
 

 
Select the Start Date and End Date for your report.  For example, if you just want the report for 
July, you could select a Start Date of July 1st, an End Date of July 31st and then click OK.  The 
report would then only show games for July.   
 
Check Show dates... if you want the date range displayed on the report if different from the entire 
Schedule Date Range. 
 
Click All to select the entire Schedule Date Range. 
 
Click Change Title and Comments to change the report title and add report comments.   
 

 

Update Game Scores 

 
 

Click on the toolbar, use Ctrl+U or select Games Scores from the Update Menu to add 
scores, forfeits, rainouts and cancelled games after a schedule has been computed. 
 
On the Update Game Scores Screen, you process games one date at a time.  Click Previous 
Month or Next Month to scroll through the months.  On the calendar, click the day of the month 
you want to work with.  Days with games added to the schedule will be blue.  The day you have 
selected will be red and the games for that date will be listed on the right. 
 
Select a game from the list on the right and click Update to enter the game score.  You can also 
double-click on the listed game to enter the game score.  If "..." is displayed next to the listed 
teams, a game score has not been entered for that game. 
 
Select Standings from the Reports Menu to display the team standings after game scores have 
been entered.  
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Edit Schedule 

 
 
Select Edit Schedule from the Update Menu, use Ctrl+E, click Edit on the Select Schedule 
Screen or click Edit on the Setup Schedule screen to add, change and delete games on a 
schedule.  All edits will be lost if you compute the schedule again.  Normally, you compute a 
schedule and then use the edit function to fine-tune the schedule if necessary.  You can also use 
the edit function to make changes during the course of the schedule being played.  You can 
manually create a schedule by using the edit function before the schedule has been computed as 
long as teams and locations have been added. 
 
On the Edit Schedule Screen, you process games one date at a time.  Click Previous Month or 
Next Month to scroll through the months.  On the calendar, click the day of the month you want to 
work with.  Days with games added to the schedule will be blue.  The day you have selected will 
be red and the games for that date will be listed on the right. 
 
Click Add, Change or Delete to update games on the schedule.  A comment for a game can be 
added to the schedule when you click Add or Change.  Click Double-Headers to create double-
headers from existing games on the schedule.  Click Swap to bring up the Swap Games on 
Schedule Screen where you can select any two games on the entire schedule and flip-flop the 
team matchups.  Double-click on "<Double-Click Here to Move Games>" at the bottom of the 
listed games to move all the games for the selected date to another date. 
 
It's a good idea to Check for Conflicts after you're finished editing a schedule.  Checking the Audit 
Report is also a good idea. 
 
Click Setup to bring up the Setup Schedule Screen.  
 

 

Edit Game 

 
 
Click Add or Change on the Edit Schedule screen to update games on a schedule after it's been 
computed.  You can also double-click on a game on the Edit Schedule Screen to change it. 
 
Select the Visiting Team, Home Team, Location, Time, Date and Game Schedule Comment and 
click OK.  Game comments are displayed on the League Schedule and Condensed Schedule and 
Team Schedule  .  The schedule is not checked for conflicts (for example, two games scheduled 
at the same time) when you add or change a game so it's a good idea to Check for Conflicts after 
you're finished editing a schedule.  Checking the Audit Report is also a good idea.  
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Swap Games on Schedule 

 
 
Swap Games is a function on the Edit Schedule Screen.  It allows you to swap team matchups for 
any two games on a schedule.  The game dates, times and locations will not change.  Select any 
two games on the schedule and click Swap.  After editing a schedule it's a good idea to Check for 
Conflicts.  The Audit Report will reflect the changes. 
 
Swap games example: 
 
Select the following two games: 
Monday   6/18/2011  Team1 vs Team2 at Elver Park at 7:00pm 
Tuesday  6/19/2011  Team3 vs Team4 at Warner Park at 6:00pm 
 
Click Swap results: 
Monday   6/18/2011  Team3 vs Team4 at Elver Park at 7:00pm 
Tuesday  6/19/2011  Team1 vs Team2 at Warner Park at 6:00pm  
 

 

Schedule Double-Headers 

 
 
Click Double-Headers on the Edit Schedule screen to create double-headers from existing games 
on a schedule.  Check the games you want to create double-headers for, enter the Minutes 
Between Starting Times, choose if you want to Switch Home Team and press OK to add double-
headers to the schedule. 
 
Check the Day of Week-Date-Location line to check all games for that date and location.  Click All 
to check all games.  Click Clear to uncheck all games.  Select a day of the week from the drop-
down list to check all games for that day.  The default Minutes Between Starting Times is the 
Length of Game entered on the Schedule Game Times screen.  Check Switch Home Team if you 
want the visiting team in the first game to be the home team in the second game.  The location 
will not change. 
 
Conflicts within the schedule and with other schedules is not checked when adding double-
headers, so it's a good idea to Check for Conflicts and look at the Audit Report after adding 
games.  
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Move Games 

 
 
Double-click on "<Double-Click Here to Move Games>" at the bottom of the listed games on the 
Edit Schedule screen to move all games for the selected date to another date. 
 
Select the date you want to move the games to and click OK.  The schedule is not checked for 
conflicts (for example, two games scheduled at the same time) when you move games to another 
date so it's a good idea to Check for Conflicts after you're finished editing a schedule.  Checking 
the Audit Report is also a good idea.  
 

 

Game Scores 

 
 
Enter a Game Score or select a Status of Visiting Team Forfeited, Home Team Forfeited, Both 
Teams Forfeited, Rainout or Cancelled. 
 
If the game ended 0 to 0, a soccer game for example, check Game Ended 0 to 0 or else the 
program will assume no game was played. 
 
If the game was an overtime game, check Overtime Game.  This could be important for the 
Standings Report because for some sports, you can assign different point values to overtime 
games in Preferences on the Standings Report.  
 
Entering a Game Scores Comment is optional. This comment is optionally shown on the Game 
Scores Report.  
 
Click Clear to clear all fields.  Clear Reset to initialize the fields to the beginning values.  
 

 

Copy Schedule 

 
 
Select Copy Schedule from the File Menu to copy a schedule.  Enter a schedule name, select a 
league, select a parameter start date, choose whether you want to copy the computed schedule, 
game scores, schedule comments and click OK.  If the day of the week for the parameter start 
date changed, if will affect the copied schedule.  For example, if the parameter start day of the 
week changed from Tuesday to Wednesday and games were scheduled on Tuesday and 
Thursday, then the copied schedule will use Wednesday and Friday for games. 
 
A schedule could be copied so it's used again for the next season or to back up a schedule. 
 
Make sure you also back up your entire database often.  
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Copy Report to Clipboard 

 
 
Select Copy Report to Clipboard from the Tools Menu to create an exact copy of the report you 
are currently viewing. This is a great option if you'd like to copy the report to Microsoft Excel.    
 
This option is only available when you are viewing a report. This option will be disabled if you are 
not viewing a report.  
 
After you've selected Copy Report to Clipboard, you'll receive a confirmation message if the copy 
was successful. Then you can start Microsoft Excel and paste the report data directly into it. From 
there you can edit and save the file just as you normally would in the application. You can also 
start an email and send the Excel file as a file attachment.  
 

 

Check for Conflicts 

 
 
This screen is displayed if you select Check for Conflicts from the Tools Menu or when you 
compute a schedule and choose to check for conflicts on the Schedule Options screen.  Only 
schedules with a game date later or equal to the current date are listed when you select Check 
for Conflicts from the Tools Menu.  Only schedules with a game date later or equal to the 
parameter start date are displayed when computing a schedule.  Select one or more schedules 
you want checked for conflicts.  The length of a game entered on the Schedule Game Times 
screen is used to determine overlapping game times. 
 
Click OK to display the Schedule Conflicts Report that shows all scheduling conflicts for the 
selected schedules or to compute a schedule without conflicts. 
 
There are four conflicts that are looked for:  

  Two games scheduled at the same time and location.  

  Team playing at 2 different locations at the same time.  

  Two games scheduled at the same location with overlapping game times.  

  Team playing at 2 different locations with overlapping game times. 
 
You can uncheck Check for Overlapping Game Times if that isn't a concern for you.  An example 
of overlapping games times is a schedule has a game length of 60 minutes and has a game 
scheduled at 7:00pm.  Another game starts at 7:30pm at the same date, time and location. 
 
Click All to select all schedules.  Click Clear to unselect all schedules.  
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Publish League Website 

 
 

Click on the toolbar or select Publish League Website from the Internet Menu to publish 
your website to the Internet with One-Click.  You can publish your website to 

www.allprosoftware.net for FREE or to your own registered domain.  Click or select 
Internet Options from the Internet Menu to select the League, Reports, Picture Gallery, Page 
Content and Export Options for your website.  If you publish to www.allprosoftware.net, you can 
select View League Website from the Internet Menu to view the website with your browser or 
select Email League Website Link to email the web address to others. 
 
During the publishing process, you can click Cancel to stop the progress before it completes.  
Note that this may cause your website to be only partially created.  If you publish the website 
later, all files created with the partially created website will be replaced. 
 
If you want to see a detailed list of what is happening during publishing, click View Details.  This 
will give you a detailed list of what is happening during the publication process.  However, this is 
mostly used to help our technical support analysts in case you have a problem publishing your 
site.  
 

 

Internet Options 

 
 

Click on the toolbar or select Internet Options from the Internet Menu to bring up the screen 
where you select the Reports, Picture Gallery, Page Content and Export Options for publishing 
your website.  Your Internet Options are saved.  Press the tabs at the top of the screen to 
navigate. 
 
Publishing Your Website 
After you select your Internet Options, you are ready to publish your website to the Internet.  You 
can either publish your site to www.allprosoftware.net or to your own registered domain. 
 
Publishing your site to www.allprosoftware.net is free.  
 
To publish your site to your registered domain, you need one of the following:  

  An existing Internet Site with an FTP UserID and Password.  

  Access to a file server or direct file access to the Web Server. 
 
Editing the Internet Template Files 
If you are an advanced user with HTML knowledge, you can edit the template files that are used 
to publish your website.  Go to www.allprosoftware.com to get instructions for editing these files. 
 

Select Reports 
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Select the reports for your website and whether you want a News Page, Links Page, Picture 
Gallery and League Contact Page.  The news and links for your site are entered under the Page 
Content Tab and the pictures are selected under the Picture Gallery Tab.   
 

Picture Gallery 

 
Select up to 10 pictures to be included in the Picture Gallery for your website.  All the pictures 
must be in the same directory and the directory must be selected as the Picture Gallery on the 
Select Schedule Screen.  You can optionally enter a caption for each picture displayed. 
 

Page Content 
 
Customize what you want displayed on your website. 
 
Website Name 
This will be displayed at the top of all the web pages. 
 
Home Page Title 
This will appear as the title on the home page of your site. 
 
Home Page Documents 
Click Add Document to add a link on the home page to a document you have created. The 
document you add can be in Microsoft Word, Microsoft Excel, Acrobat PDF, or text. Use this to 
provide information such as league rules, concession stand dates/hours, uniform order sheet, etc. 
People viewing the website will be able to click on this link and view or print the document.  
 
Home Page Greeting 
Enter a greeting for the home page of your website. 
 
Link Page Greeting 
Enter a short paragraph describing the Link Page. 
 
Link Page Links 
This area holds the HTML that will be used for the links.  Click Add Link to add a link.  You don't 
need to know HTML to add a link.  However, advanced users can directly edit the HTML. 
 
News 
This area holds the HTML that will be used for the News Page.  Click Add News to add a news 
item to your website.  You don't need to know HTML to add a news item.  However, advanced 
users can directly edit the HTML. 
 

Appearance 

 
Colors 
Customize the background colors and font colors for the two banners shown at the top of the 
website. Just click on the buttons and choose a color.  
Logo 
Optionally add an image (e.g. school logo) to display on your website.  
Click on the check-box to display the image in the top right, top left, or centered on the home 
page. You can control the size of the image displayed by entering the pixel height. The image on 
the banner and the home page can be different sizes. When you change the pixel height, you'll 
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see the image size previewed on this page. The pixel height must be between 20 and 999.  
Click Find Logo to browse for your image.  
 

Export Options 

 
You can export your website to www.allprosoftware.net for FREE with the All-Pro Web option or 
to your registered domain by using the FTP Options.  You can also create HTM files for each 
report in a File Directory on your computer with the File Directory Options. 
 
All-Pro Web: 
 
Check this option if you want to export your site to www.allprosoftware.net for FREE.  With One-
Click you can have your own website up and running, after you select your Internet Options. 
 
FTP Options: 
 
Export using FTP 
Check this option if you want to use FTP to export your site to your own Internet domain.  You 
must fill in the rest of the FTP Options section of this window. 
 
Warning message if Default Page already exists 
Check this option if you want to be warned if a default.htm file already exists.  This might prevent 
you from overwriting the main page of your website inadvertently. 
 
FTP URL 
This is the URL (FTP site name) where you will be publishing your site.  For example, 
ftp.allprosoftware.com. 
 
FTP Directory 
Enter the directory where you wish to save the site.  WARNING: If you leave this blank, the site 
will be published to the root of your website and may overwrite your existing files! 
 
User ID 
Enter your FTP UserID. 
 
Password 
Enter your FTP password. 
 
Test Connection 
After you enter your information, click this button to upload a small test file to the directory.  If this 
works, you are ready to publish your site! 
 
File Directory Options: 
 
Export to file directory 
Check this option if you wish to save your site to a network file server or local directory on your 
hard drive and enter the directory path.  Click Browse to use Explorer to locate the directory 
where you wish to save your website. 
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Add Link 

 
 

To add a link: 

  Enter a Link Name.  For example, All-Pro Software  

  Enter a Link URL.  For example, http://www.allprosoftware.com. 

  Enter a Link Description.  For example, The Best Sports Software Site on the Internet.  
 

 

Add News 

 
 
Enter the news item you want to add to your site and click OK.  The HTML will be added to 
display the date and time when the news item was added.  
 

 

All-Pro Web URL 

 
 
The first time you publish your All-Pro League Website you must enter a Web Name.  This name 
will be a sub-directory off of www.allprosoftware.net.  It is important to note that you will not be 
able to change the Web Name after you enter it so be thoughtful of your choice. 
 
You could use the name of your league for the Web Name.  
 

 

Find Picture 

 
 
Select the Picture Gallery directory and picture for the Select Schedule Screen where all pictures 
in the Picture Gallery directory can be viewed.  When you install the League Scheduler, a, 
Pictures directory is created (\Program Files\All-Pro League Scheduler\Pictures).  You can copy 
the pictures you want to view to this directory (not a program function) or you can select another 
directory. 
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Options 

 
 
Select Options from the Tools Menu or use Ctrl+O to customize the League Scheduler.  The two 
sections of the Options Screen are Reports and General.  Click on the tab to view the options 
available for each section.  Below is a list and description of the options available. 
 

Reports 

  Display Report after Compute - Select whether to show the League Schedule, Condensed 

Schedule, Team Schedule, or Audit report after a schedule is computed.   

  Display on Reports - Select whether to use "at" or "vs" before home team on reports. 

  Report Colors - Click on the text to change the color for the Report Title, Schedule Name, 

Date Range and Detail Section for the reports.   

  Report Zoom Control - Set the default Zoom Percentage for the reports.   

  Show Date - Check to show the current date at the bottom of the reports.  
 

General 
 
Database Location - The folder where your database is stored is displayed. Click Browse to 
change the location. If you have multiple licenses, you can change the database location to a 
shared network drive so everyone can access the same data. You'll need to install the program 
on each individual computer and then change the location of the database to a shared network.  
 
Screen Colors - Click on the Main Screen, Window or Text to set the program colors.  Click 

Match Button Color to make the window color match the Windows button color.   
 
Game Times - Show times every 1, 5 or 15 minutes on the Game Times Screen.  
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Back Up Database 

 
 
Select Back Up Database from the File Menu to make a copy of your League Scheduler 
database. Select where you want to save your backup file and then click Save.  
 
If you plan to run the League Scheduler on two computers, home and work, you can back up 
your database to a USB flash drive (also called a jump drive or thumb drive) and then load it to 
the other computer using the Restore Database function on the File Menu.  
 
We recommend backing up your data to your hard drive and also a USB flash drive.  This way 
you have a backup copy you can quickly restore from on your hard drive and an external copy on 
a flash drive to recover from if you ever experience problems with your hard drive.  Another good 
option is to backup your data to your hard drive and then create an email and add the backup file 
as an attachment and send it to your work email address.  That way you can save the backup file 
on another computer and recover your data if you experience problems with your hard drive.  
 
There is an emergency backup that may be useful in recovery if no other backup exists. This file 
is named apsls.bak or apsls.bak2.  
 

 

Restore Database 

 
 
Select Restore Database from the File Menu to replace your League Scheduler database with a 
backup file created using the Back Up Database function on the File Menu.  All data in your 
database will be overwritten with what is on the backup file so be sure you want to do this before 
proceeding!   
 
Select where your backup file is located and click Open. 
 

 

 
If you plan to run League Scheduler on two computers, home and work, you can back up your 
database to USB flash drive using the Back Up Database function on the File Menu and then load 
it to the other computer using the restore database function.  
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Import Teams and Locations 

 
 
Select Import Teams and Locations from the Tools Menu to import a file of information. This can 
save you some time typing if you have lots of team names and you already have an Excel file 
listing them. Team names and location names can also be imported from several of All-Pro's 
other software programs including Tournament Scheduler, StatTrak for Baseball & Softball, 
StatTrak for Volleyball, StatTrak for Hockey, StatTrak for Basketball.  
 
To import teams and locations from All-Pro's StatTrak programs, first start the StatTrak program 
and use the Back Up Database functions in the File Menu to create a file. Then in League 
Scheduler, select Import Teams and Locations from the Tools Menu, select the file you created 
during the Backup and click Open. Teams and Locations from the Backup file are imported into 
League Scheduler. Now you can proceed to Setup Schedule and assign the Teams and 
Locations to a specific schedule. To import from Tournament Scheduler, import the tournament 
file (file extension TRN) instead of the Backup file.    
 
To import teams and locations form a comma delimited file there are 3 main steps:   
 
1.  Create your comma delimited file. 
2.  Assign all columns in your comma delimited file to a corresponding field in League Scheduler.  
3.  Import your data. 
 
Step 1 - Create Comma Delimited File (CSV) 
Prior to the import, you need to create a comma delimited file from Excel, or another software 
program where the team names or locations you want to import reside.  This is a standard file 
type.  You should be able to find out how to create a comma delimited file in the help section of 
these programs (probably under import/export).  A comma delimited file is also called a comma 
separated file.  The file extension is CSV which stands for comma separated values. Create one 
file for Teams and another for Locations.  
 
Click on the Tools Menu and select Import Teams and Locations. Click Browse to select the 
comma delimited file and then click Open.  
 
The Comma Delimited Import Screen is then displayed. This is where you assign each column of 
import data to a corresponding field in League Scheduler.   
 
Step 2 -  Assign Columns  
Some Comma Delimited files contain the column name as the first row in the data. If this is the 
case for your file, you can specify 'Skip 1st Row' so the column titles do not get imported as 
information. 
 
Now you must assign each column of data you wish to import in the file to a field. Click on each 
column and choose the appropriate field. Note that the field names will be different depending on 
if you choose Team or Location in the previous listbox.  
 
The Choose Fieldname to assign window appears after you click on a column in the Import 
Comma Delimited window. Choose a field name to assign to the column you just clicked on. 
When importing teams, all the contact information is optional. You can just import the name.  
 
Step 3 -  Import  
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Once all the appropriate columns have been assigned to a field click Import. Now you can 
proceed to Setup Schedule and assign the Teams and Locations to a specific schedule.  
 

 

 

 

 

 

 

Export Schedule 

 
 
Select Export Schedule from the Tools Menu to create a file containing schedule information. The 
default name for the export file is "League Scheduler Export" but you can change this name to 
whatever you'd like. Click on Browse to change where the file is saved on your computer. By 
default all schedules within a league are selected (with a checkmark). Uncheck any schedules 
you don't want to export information for.     
 
There are 4 different file formats. Choose Comma Delimited (also called comma separated) if you 
want to open the export file using Excel. The export file created will have a file extension of CSV. 
The other 3 formats are for different calendar programs, iCalendar (ICS), vCalendar (VCS), and 
Google Calendar.   
 

 

 

Export User Database 

 
 
Select Export User Database from the Tools Menu to create your own access database for the 
leagues you select.  The default name for the database is UserDatabase.mdb but can be 
whatever you like as long as the file extension is .mdb. The default directory is \Data\backup but 
you can create the database wherever you want.  This user database is NOT compatible with the 
password protected proprietary League Scheduler database and is much less complex.  
 

 

Technical Support 

 
 
For technical support: 
 
Click on the Help button or Press F1 on any screen to view detailed help.   
 
For additional help, visit our technical support website page 
www.allprosoftware.com/Technical Support  
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Send Us Your Data 

 
 
Select Send Us Your Data from the Help Menu to submit a problem to All-Pro.  
 
Name and Email are required. Phone is optional. The Helpdesk Problem ID is optional. Please 
enter in this if you already have a problem ID from All-Pro.  
 
In the Description, please include a full description of the problem, including any specific error 
numbers and messages.  
By providing us with a complete description we'll have a better chance of resolving the problem 
for you.   
 
You may find an answer to your question right away in the Frequently Asked Questions section.  
 

 


